Welcome Anonymous !


 


Alpha Squad US TeamSpeak Viewer

Arma Android Development

The forum dedicated to creating missions for ARMA. Share your missions and your knowledge to others here !

Re: Arma Android Development

Postby Splint » Sat Sep 20, 2014 7:27 pm

I got it to work after using the dll from TS channel. The map showed up and indicated my location but every few seconds it disappeared and said waiting for arma connection, then came back on it's own. After about a minute, app crashed. I could not start it again because it got stuck in "Unfortunately, Arma Connect has stopped". I press OK, same thing. Logs: http://ge.tt/2u1tVBy1/v/0


Ya I should have read all the posts more carefully. I was tired and pressed for time. Got the dll and will test it again on Sunday when I have access to the Android.

Update to follow.
“That’s what I’ve been – I say, that’s what I’ve been telling you, boy!”
User avatar
Splint
 
Posts: 938
Joined: Sat Mar 28, 2009 8:47 pm
Location: Nevada

Re: Arma Android Development

Postby Firefly_AS » Sat Sep 20, 2014 9:21 pm

@Robalo: Extremely minimal bandwidth. I think it's just a bug with the code and how it considers it "connected". I'll take a look.
User avatar
Firefly_AS
--------------
--------------
 
Posts: 996
Joined: Thu Apr 29, 2010 4:13 am
Location: US

Re: Arma Android Development

Postby Firefly_AS » Sun Sep 21, 2014 6:22 am

Fixed/added some stuff this evening. I think I found a major issue but it's tough to test. It has to do with the data length being too long and crashing. I bet this may be the crash you experienced Rob.
User avatar
Firefly_AS
--------------
--------------
 
Posts: 996
Joined: Thu Apr 29, 2010 4:13 am
Location: US

Re: Arma Android Development

Postby Firefly_AS » Sun Sep 28, 2014 5:18 am

User avatar
Firefly_AS
--------------
--------------
 
Posts: 996
Joined: Thu Apr 29, 2010 4:13 am
Location: US

Re: Arma Android Development

Postby Hatchet_AS » Wed Nov 05, 2014 9:09 pm

I still can not get this to work locally for me! ;badnade
User avatar
Hatchet_AS
--------------
--------------
 
Posts: 1090
Joined: Wed Aug 22, 2012 8:47 pm

Re: Arma Android Development

Postby Firefly_AS » Thu Nov 06, 2014 1:14 pm

Hmm interesting. Yeah I really want to work on this but real life stuff is taking a priority. I've been doing so much programming for work/school... it's not exactly what I want to do when I get home.
User avatar
Firefly_AS
--------------
--------------
 
Posts: 996
Joined: Thu Apr 29, 2010 4:13 am
Location: US

Re: Arma Android Development

Postby Firefly_AS » Sat Nov 22, 2014 5:40 pm

@Hatchet: Any chance you could help with the map image for Altis?
User avatar
Firefly_AS
--------------
--------------
 
Posts: 996
Joined: Thu Apr 29, 2010 4:13 am
Location: US

Re: Arma Android Development

Postby Hatchet_AS » Sun Nov 23, 2014 6:10 am

Oh yeah, that. Mkay. Will try to fix it up tomorrow, it's mostly in one piece now.
User avatar
Hatchet_AS
--------------
--------------
 
Posts: 1090
Joined: Wed Aug 22, 2012 8:47 pm

Re: Arma Android Development

Postby Hatchet_AS » Thu Nov 27, 2014 12:22 am

Almost fixed it all up the other day, but had some odd tiling issue on the bottom and right sides. Need to fix that.. fortunately a 'mostly automated' process now. So... doing other maps should be trivial. Sorry for the delay, lots of things going on in general.
User avatar
Hatchet_AS
--------------
--------------
 
Posts: 1090
Joined: Wed Aug 22, 2012 8:47 pm

Re: Arma Android Development

Postby Firefly_AS » Tue May 26, 2015 5:35 am

I'm going to try to get back into this. I made a few corrections (I hope) this evening but I'm still hitting some really rough concurrency and/or race conditions. Bleh. :-\
User avatar
Firefly_AS
--------------
--------------
 
Posts: 996
Joined: Thu Apr 29, 2010 4:13 am
Location: US

Re: Arma Android Development

Postby Hatchet_AS » Tue Aug 04, 2015 5:38 pm

Eh?
User avatar
Hatchet_AS
--------------
--------------
 
Posts: 1090
Joined: Wed Aug 22, 2012 8:47 pm

Re: Arma Android Development

Postby Firefly_AS » Wed Aug 05, 2015 12:34 am

Technical things, I just need to look more into debugging. Threading is difficulty to debug. :P
User avatar
Firefly_AS
--------------
--------------
 
Posts: 996
Joined: Thu Apr 29, 2010 4:13 am
Location: US

Re: Arma Android Development

Postby Firefly_AS » Wed Jun 22, 2016 5:06 am

Think I got a new (better?) build system (Gradle) working. Switched to Android Studio for development from Eclipse. Also started work on updating the TileView library that's used for displaying. They made some performance tweaks in 2.X but ended up breaking it so it's not backwards compatible to 1.X.

Quickly tested it and the weather and time information seems to work after all this time (yay!)
The map is broken though (boo...)
User avatar
Firefly_AS
--------------
--------------
 
Posts: 996
Joined: Thu Apr 29, 2010 4:13 am
Location: US

Re: Arma Android Development

Postby Hatchet_AS » Thu Jun 23, 2016 3:04 pm

I'll try to setup foo to test this again. Hopefully it works on the Turbo.
User avatar
Hatchet_AS
--------------
--------------
 
Posts: 1090
Joined: Wed Aug 22, 2012 8:47 pm

Re: Arma Android Development

Postby Firefly_AS » Fri Jun 24, 2016 2:43 am

I'm gonna be doing some major work on it so I would hold off for now. The map images would help though :)
User avatar
Firefly_AS
--------------
--------------
 
Posts: 996
Joined: Thu Apr 29, 2010 4:13 am
Location: US

PreviousNext

Return to ARMA :: Mission Editing

cron
  • View new posts
  • View unanswered posts
  • Who is online
  • In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 3 minutes)
  • Most users ever online was 311 on Wed Dec 12, 2018 4:22 pm
  • Users browsing this forum: No registered users and 1 guest
Presets
Main Style
Patterns
Accent Color
Apply